icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.cts-cd.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

北京快乐8 www.170265.com-上海快三500期| www.408062.com-濮阳市彩钢厂| www.565464.com-网络代打彩票分红| www.577743.com-阳光彩票代理加盟| www.656611.com-北京彩票店转让信息| www.754822.com-黑彩快三怎么拉人| www.826478.com-苏宁彩票幸运28| www.894472.com-彩票智能选号工具| www.961324.com-彩专家在线| 500彩票网www.61655t.com| www.275187.com-彩票中奖不捐款挨骂| www.381716.com-妙彩彩票-| www.542038.com-广州超大彩箱厂| www.096866.com-排五走势彩宝网| www.301642.com-湖北福彩快三分布图| www.62fa.com-五彩斑斓的世界剧透| www.0558.live-大乐透电子彩报| www.8237.bid-今天江西快三走势图| www.379013.com-体育彩票加盟费用| www.127207.com-古风眼睛彩铅| www.229353.com-梦想彩票app| www.177967.com-爱彩乐彩票-| www.313569.com-河北快三是不是骗局| www.20759.com-彩票18彩金-| www.121350.com-报警能把黑彩钱追回| www.279044.com-重庆时时彩龙虎和| www.an74.com-贵州省体育彩票中心| www.zl53.com-双彩论坛图迷专区| www.70yq.com-3d彩票字谜总汇| www.229716.com-2019彩票网-| www.31163.cc-快三复式万能5码| www.007061.com-手机qq彩票在哪里| www.879584.com-福彩门户免费资料| www.979473.com-彩金价格-| www.817485.com-传统足彩彩票资讯| www.917038.com-亚彩彩票安全吗| www.991787.com-彩民之家论坛| www.sa5.com-时时乐开门彩| www.sh63.cc-五分时时彩开奖记录| www.17wl.com-七乐彩中奖2个号| www.83ze.com-彩富网与你同行免费| www.023409.com-七乐彩下期预测| www.234892.cc-3b福彩-| www.276373.com-时时彩一码倍投方案| www.6684.cn-彩票可能有赢家吗| www.24827.com-二年级彩铅画| www.gw14.com-幸运快三骗局揭秘| www.p17.cn-美国彩票规则介绍| www.64lo.com-下载众彩网安全吗| www.854596.com-中国258竞彩网| www.954883.com-福彩七乐彩兑奖规则| www.cai0033.com北京快3开奖爱彩乐| www.j04.cn-手机棋牌游戏送彩金| www.66sa.com-七乐彩奖金分配| www.eg44.cc-乐发彩票app下载| www.588575.com-注册彩票站多少钱| www.490031.com-七乐彩奖池走势图| www.606833.com-今日福彩3d奖号| www.cp846.com-幸运快三有什么猫腻| www.93bd.com-彩票的三个原理| www.9023.net-今日七星彩预测头尾| www.777784.com-中国彩吧网下载安装| www.824.me-上海福利彩票网官网| www.8200.cn-玖富彩票西-| www.247959.com-中国福彩有多假| www.333340.com-豪彩vip-| www.438268.com-七星彩今晚现场直播| www.bm79.com-福彩30万都是托| www.019743.com-广西北海彩票快三| www.359595.com-福利彩票最晚几点买| www.541124.com-亚洲塚本彩-| www.38001.com-贵州省体彩十一选五| www.9008.cc-乐彩彩票开奖结果| www.83oe.com-香港好彩堂资料| www.4171.top-七彩云染料-| www.787711.com-彩客科技-| www.852939.com-彩宝彩票能提现吗| www.919999.com-网上买彩票能挣钱吗| www.976269.com-七星彩在什么店买| www.440.org-246天天彩彩票| www.25380.com-彩铅桃花画法| www.001594.com-七乐彩胆拖奖金| www.51375.com-网上买黑彩犯法吗| www.315836.com-手机版2d彩虹六号| www.768028.com-吉利三分彩开奖结果| www.141490.com-鸣彩艺术官方网站| www.235231.com-中国福彩预测下载| www.329081.com-青海福彩网app| www.389653.com-五分快三多少期龙| www.135254.com-一品彩票平台| www.215868.com-七星彩计算公式| www.223768.com-湖南体育彩票官网| www.301620.com-今天七星彩现场直播| www.512006.com-漂亮简单的彩铅画| www.635307.com-七彩本草滴丸| www.783143.com-石家庄体彩中心在哪| www.853667.com-足彩310官网下载| www.921009.com-全球彩票网址是什么| www.978425.com-彩色路面施工工艺| www.kf05.com-福利彩票奖励规则| www.c89.club-七星彩360-| www.76zo.com-多玩彩票提现| www.1213.tv-五万彩礼-| www.111564.com-e8发彩网购彩平台| www.221587.com-520彩票下载| www.313479.com-好彩堂开奖网站| www.382207.com-中港彩票app下载| www.643565.com-九彩拱北老人家相片| www.724444.com-彩票最后买中奖高吗| www.806025.com-福彩3d奖号走势图| www.870652.com-易旺彩票注册邀请码| www.935789.com-刘大军中彩网| www.985146.com-728彩票怎么没了| www.te49.com-福州福彩中心在哪里| www.505198.com-63彩票送彩金| www.609162.com-体育彩票站几点上班| www.tn77.com-5分快三破解器视频| www.718605.com-彩虹的配色-| www.814163.com-网络博彩怎么玩| www.761503.com-体彩6十1复式玩法| www.145937.com-360彩票567-| www.256713.com-安徽快三预则一定牛| www.318462.com-火箭彩票app下载| www.610152.com-淘宝买彩票怎么兑奖| www.688299.com-竞彩中奖-| www.289316.com-78彩票推荐人| www.650671.com-早教彩虹伞-| www.720505.com-七星彩43开-| www.805499.com-彩票行业现状| www.871762.com-福彩刮刮乐中奖图片| www.954309.com-星彩3d八宝菜惊| 快彩在线www.2632m.com| www.276809.com-王牌彩票可不可靠| www.368022.com-刚力彩芽爱情| www.944876.com-假福彩-| www.994420.com-微彩靠谱吗-| www.cx01.com-海南私彩有app| www.1598.bid-合肥福彩中心在哪里| www.8563.net-时时彩代理判刑案例| www.413300.com-福建省足彩培训师| www.514711.com-澳洲彩票种类| www.595795.com-鑫彩公司-| www.8145.cm-福彩一休三天计划胆| www.0472.date-京东彩票微信客服| www.9679.cm-港彩慈善网-| www.33413.com-排列三杀号凤彩网| www.323483.com-七乐彩开奖视频直播| www.392585.com-株洲福彩新闻| www.163552.com-网易彩票-| 金冠彩票www.49956o.com| www.560452.cc-非凡彩票是真是假| www.336758.com-广西快3彩票2元网| www.052139.com-六喝彩开奖查询结果| www.708484.com-陌陌彩票女-| www.791201.com-我要买彩票排列三| www.857122.com-菲律宾博彩平台| www.921185.com-福彩3d跨度| www.969522.com-奖多多的酷彩吧| www.cp7295.com-易彩快3合法吗| www.jq94.com-七天彩app-| www.zm56.com-体彩任九的玩法| www.15vs.com-体彩如何经营| www.74et.com-排三预测家彩网杀码| www.1413.vip-66彩票50616|